When i start up, game goes black and shut down.

Discussion in 'Technical Issues' started by EnigmaticAlly, Nov 23, 2011.

Old topic!
The last post in this thread is over 60 days old. Posting in this thread will be considered a bump, so please make an attempt to be courteous if you go ahead with it.

If the last post is over 6 months old, it may instead be a better idea to start a new topic. If you aren't sure about what to do, feel free to ask a staff member for help, or try to locate a 'general questions'-type thread if it exists in this (sub-)forum.
  1. Nov 23, 2011
    Neophyte Member
    "Fresh from the Bakery"
    Join Date: Nov 23, 2011
    Posts: 3
    Just bought the game on Steam. I was very excited to play it. However, whenever I start the game up, it takes me to a black screen....and nothing happens. I've tried everything, too. I've verified game cache, uninstalled/re-installed, checked to make sure my compatibility settings were executable.. Nothing is working!

    Help me! :p
  2. Nov 23, 2011
    gigantic immortal cat
    "Bleep, Bloop, Bleep, Bloop"
    Join Date: Apr 18, 2006
    Location: Forever wandering the tower...!
    Posts: 1607
    Is it for the PC or for the MAC?

    What kind of system do you have? XP, Vista, 7?

    You were able to install the game fine?

    Are there any error messages? How do you close it, when it freezes up with a black screen?

    What kind of video card do you have? What resolution are you using?
    When it goes to a black screen, if you press Z several times for 20-30 seconds does anything happen (any sounds perhaps)?

    Is it a laptop or a desktop (or something else)?

    Have you tried to change the resolution to something small, and then run the game?

    Can you alt-tab out of the game when it loads that black screen, and then come back?

    Hmm......... what else...........................

    Also, have you tried installing it on another computer just to see if it works elsewhere?

    BTW :
    HAve you tried posting this on the official forum for CaveStory+?


    Hmm... uh try this :

    Download the msvcr100.dll (It comes in a ZIP file, so extract that) [Not the dll fixer thing]

    And put it into your Cave Story+ application directory.
    (My Cave Story+ directory was : C:\Program Files\Steam\steamapps\common\cave story+ )
    Throw that .dll in there if it doesn't already exist.

    Now open Steam and try hitting play again... Any luck? (It's worth a shot)
  3. Nov 25, 2011
    Neophyte Member
    "Fresh from the Bakery"
    Join Date: Nov 25, 2011
    Posts: 3
    I have the same issue here, bought the game on steam, but when i go into it the screen goes black and does nothing.
    If i minimise theres a "cave story stopped responding" box.

    Desktop Specs:
    - Core i7
    - 4Gb ram
    - Radeon HD5850 (1920 x 1080)
    - Windows 7 Ultimate SP1 32bit fully updated.

    also tried defragging game files and uninstalling/reinstalling. (Game installs fine)
    tried the dll thing in previous post too.(no luck)
    Have also tried a few things that normally work with other games :mrgreen:

  4. Nov 25, 2011
    Cave Story
    Member Title
    "All your forum are belong to us!"
    Join Date: Mar 9, 2011
    Posts: 629
    Age: 19
    Try to activate the application manually through program files. I remember a similar issue occurred with me on L4D2, and I believe it's just the Steam launcher malfunctioning; a manual launch should fix it. Get back to me whether it works or not.
  5. Nov 25, 2011
    Neophyte Member
    "Fresh from the Bakery"
    Join Date: Nov 25, 2011
    Posts: 3
    If i run the exe from program files i can see the process in task manager, but it doesnt do anything, no black screen, no error, no sounds, nothing.
    and then i end task :S
    *Also tried compatibility mode(s), and "as administrator"
  6. Nov 26, 2011
    Little Bitch in Sheep Clothing
    Join Date: Nov 16, 2011
    Location: New Zealand/ Thailand
    Posts: 352
    Age: 19
    You should try if it works on another computer.
  7. Nov 29, 2011
    Neophyte Member
    "Fresh from the Bakery"
    Join Date: Nov 25, 2011
    Posts: 3
    Found the solution, i switched OFF Triple Buffering in my display card options (ATI Catalyst)
    Now its working perfectly :D
  8. Dec 22, 2011
    Novice Member
    "Officially Worth 1 Rupee"
    Join Date: Dec 22, 2011
    Posts: 1
    Same problem here.
    Disabling Triple Buffering did nothing, but I suppose it's because my graphics card is assbad.
    Might try using 3D Analyze or something, which is absurd, because it's a 2D game and I can run the original version fine.
  9. Dec 22, 2011
    Lvl 1
    "Life begins and ends with Nu."
    Join Date: May 28, 2008
    Location: PMMM MMO
    Posts: 3708
    Age: 25
    Original Cave Story uses a very old rendering method (and is actually more CPU intensive on most new computers because of it) so running the original doesn't mean the new one will run.
  10. Dec 24, 2011
    Novice Member
    "Officially Worth 1 Rupee"
    Join Date: Dec 24, 2011
    Posts: 1
    I get the same problem here :p.. both trough steam as trough humbebundle download... and it was the only reason I bought this humble bundle!! :(

    Anyway, windows 7 64bit..

    I could not find this 'triple buffering' thing in my catalyst (amd) or whatever... I guess ill search harder if it can be the solution..